Raspbian Busterでdockerがインストールできない

ガジェット

インストールスクリプトを走らせるとエラーが起きる

pi@raspberrypi1:~ $ curl -sSL https://get.docker.com | sh
...
E: Package 'docker-ce' has no installation candidate

環境

Raspbian Busterを使っています

pi@raspberrypi1:~ $ uname -a
Linux raspberrypi1 4.19.57-v7+ #1244 SMP Thu Jul 4 18:45:25 BST 2019 armv7l GNU/Linux

原因

Docker Inc. がRaspbian Busterのパッケージを後悔していないらしく、使えないっぽい

Raspbian Busterだと動かない

のでStrech入れましょう
ダウンロード先

参考

Learn how to fix installation errors when installing Docker on your new Raspberr…
blog.alexellis.io

Description Is 'docker' available via curl script for Buster / Debian 10…
github.com